Cannot get mobs to spawn on server

Discussion in 'Minecraft Community Support' started by Ravnos, May 8, 2019.

  1. Ravnos

    Ravnos
    New Member

    Joined:
    May 6, 2019
    Messages:
    3
    Likes Received:
    1
    Trophy Points:
    3
    Hello everyone

    This is my first time running a Minecraft server so I apologize for the newbness. I can't seem to get mobs like skeletons and creepers to spawn in the world naturally. Spiders spawn in caves next to creature spawn bricks but they're the only ones. I've tried using the following command:

    /gamerule doMobSpawning true

    I've also made sure that my game is set to normal difficulty and not peaceful or easy.

    I'm running no mods or plugins. I'm simply running a vanilla 1.14 server.

    Any help is appreciated.
     
  2. Richard_BN

    Richard_BN
    BeastNode Staff

    Joined:
    Dec 18, 2015
    Messages:
    536
    Likes Received:
    135
    Trophy Points:
    108
    Gender:
    Male
    Occupation:
    BeastNode Support Agent
    Location:
    The Realm of Obscurity.
    This is a bug in Vanilla 1.14 itself - they are spawning, just not near you. Mobs do not despawn correctly on 1.14, meaning there will be mobs further away from you that are inactive but have not despawned as they normally would so new mobs won't be spawning around you.

    The only fix for this on 1.14 is to increase the view-distance in the server.properties to try and force the mobs further away from you to become active and despawn however this is very strongly advised against doing.
    Increasing this setting at all will also increase the server load due to more chunks and entities being active on the server - even on a stable server version on shared hosting (such as 1.12.2 or older) this is very strongly advised against as the systems CPU is not dedicated to your server. Doing this on 1.13+ will cause the server to become more or less unplayable as these versions are already unstable - particularly 1.14 - in general it is advised to lower this setting on 1.14 for performance-sake.

    1.14.1 is around the corner and should fix this, as this is one of the issue listed as fixed in the first 1.14.1 pre release.
     
    Ravnos likes this.
  3. Ravnos

    Ravnos
    New Member

    Joined:
    May 6, 2019
    Messages:
    3
    Likes Received:
    1
    Trophy Points:
    3
    Oh I see. Good to know, thanks for the info.

    I'll do a backup and upgrade to the pre-release and see how that goes.

    Thanks again.
     
    Last edited: May 9, 2019
    Richard_BN likes this.
  4. Ravnos

    Ravnos
    New Member

    Joined:
    May 6, 2019
    Messages:
    3
    Likes Received:
    1
    Trophy Points:
    3
    This does not appear to have been fixed in the new update, at least for me. I've played around with it a little and even rebuilt a world from scratch after a backup but still no spawns. Changed the difficulty all the way up to hard but no dice. Built a portal to the nether and no spawns in there either.

    Any other thoughts? Kind of frustrating.
     
  5. Richard_BN

    Richard_BN
    BeastNode Staff

    Joined:
    Dec 18, 2015
    Messages:
    536
    Likes Received:
    135
    Trophy Points:
    108
    Gender:
    Male
    Occupation:
    BeastNode Support Agent
    Location:
    The Realm of Obscurity.
    If you've put the view distance back to 10 and have correctly updated to 1.14.1 (run it via the - -forceUpgrade option once first) then the issue should be fixed as far as Mojangs changelog for 1.14.1 is concerned.

    If its not then you need to go and report this on their bug tracker so they know its still an issue.
     

Share This Page