JAR List Updates December 1st-31st 2020

Richard_BN

BeastNode Staff
Dec 18, 2015
552
128
108
The Realm of Obscurity.
December 2nd Updates

JAR List Options that have been added:
- AT - A Bit of Everything (3.8.5).
- Curse - All The Mods 6 (1.3.3).
- Vanilla 1.17 Snapshot 20w49a.

JAR List Options that have been updated:
- The Fabric 1.14.4 option, updated to use Fabric Loader (0.10.8).
- The Fabric 1.15.2 option, updated to use Fabric Loader (0.10.8).
- The Fabric 1.16.4 option, updated to use Fabric Loader (0.10.8) and to include Fabric-API (0.27.1).
To update these options simply delete the jar folder and restart. If you have renamed the Fabric-API.jar file in the mods folder at any time this must also be deleted or it won't auto-remove and update correctly (nothing else in the mods folder is touched so it won't effect your installed mods when updating).

JAR List Options that have been removed:
- AT - Caved IN (3.0.8.4).
- Vanilla 1.17 Snapshot 20w46a.



Remember to keep up to date with the options tagged with [Latest] on the jarlist if you use them - updates for these are found on the first link below, and the second link lets you know how to update if you use these options:
https://www.beastnode.com/forums/threads/jar-list-latest-updates.143/
https://www.beastnode.com/forums/threads/latest-jar-list-options-and-how-when-to-update-them.174/
 

Richard_BN

BeastNode Staff
Dec 18, 2015
552
128
108
The Realm of Obscurity.
December 9th Updates

JAR List Options that have been added:
- Curse - Roguelike Adventures and Dungeons (1.41).

JAR List Options that have been removed:
- AT - A Bit of Everything (3.8.4b).
 

Richard_BN

BeastNode Staff
Dec 18, 2015
552
128
108
The Realm of Obscurity.
December 11th Updates

JAR List Options that have been removed:
- Curse - Roguelike Adventures and Dungeons (1.40a).


We have made a few changes to the Jar List.

We will now list separate "Unsupported" categories on the jar list.
These are for outdated server versions/softwares that are no longer recommended for use - they are there for you to use if you wish to, however you do so at your own risk of bugs/issues that would not be present if you used more up to date software and the support we can give for issues on those options is also more limited as a lot of the time the answer is simply to update.

Of the options that were on the list previously the following are now listed under an "Unsupported" category on the list:
- NukkitX.
- All 1.17 Minecraft Snapshots.
- All Vanilla/Spigot/PaperSpigot options excluding the latest three major release builds (ie currently 1.14.4, 1.15.2 and 1.16.3/4 are still in their normal sections).

Forge/Modded options have not been split into separate categories, as older modpacks/Forge versions are still "supported". However - there may be an "Unsupported" section for certain packs at a later time.

Along with this change we have also decided to re-add a back catalogue of older/legacy options so you can choose to use them without needing to manually install them - but again, we do not support their use.

The returning options are:
- Vanilla/CraftBukkit 1.2.5.
- Vanilla/CraftBukkit 1.3.2.
- Vanilla/CraftBukkit/Spigot 1.4.7.
- Vanilla/CraftBukkit/Spigot 1.5.2.
- Vanilla/CraftBukkit/Spigot 1.6.4.
- Vanilla/CraftBukkit/Spigot 1.7.10.
- Spigot/PaperSpigot 1.8.8.
- Vanilla 1.8.9.
- Vanilla/Spigot/PaperSpigot 1.9.4.
- Vanilla/Spigot/PaperSpigot 1.10.2.
- Vanilla/Spigot/PaperSpigot 1.11.2.

All CraftBukkit/Spigot/Paper options are their last releases for that MC version.

- Vanilla 1.17 Snapshot 20w45a.
- Vanilla 1.17 Snapshot 20w46a.

For Snapshots/Pre-Releases/Release Candidates we will keep all of these options for the next major release, rather than just the most recent two (ie currently all 1.17 snapshots/pre-releases/release candidates) and they will be removed at the same time as the full release is added to the list in the future.

At this time we do not plan to add 1.0.0, 1.1 or Alpha/Beta builds of Minecraft - their use will still require manual installation.
 

Richard_BN

BeastNode Staff
Dec 18, 2015
552
128
108
The Realm of Obscurity.
December 13th Updates

JAR List Options that have been added:
- PixelmonGenerations (8.2.1).

JAR List Options that have been updated:
- The Fabric 1.16.4 option, updated to include Fabric-API (0.28.1).
To update this option simply delete the jar folder and restart. If you have renamed the Fabric-API.jar file in the mods folder at any time this must also be deleted or it won't auto-remove and update correctly (nothing else in the mods folder is touched so it won't effect your installed mods when updating).
 

Richard_BN

BeastNode Staff
Dec 18, 2015
552
128
108
The Realm of Obscurity.
December 16th Updates

JAR List Options that have been added:

- PixelmonGenerations (8.2.2).
- Forge 1.16.4 (Rec. - 35.1.4).
- Curse - All the Mods 6 (1.3.4c).
- Vanilla 1.17 Snapshot 20w51a [Unsupported].

JAR List Options that have been removed:
- PixelmonGenerations (8.1.3).
- Forge 1.16.3 (Rec. - 34.1.0).
 

Richard_BN

BeastNode Staff
Dec 18, 2015
552
128
108
The Realm of Obscurity.
December 16th Updates - Part 2

As with the previous changes for older versions being under "Unsupported" categories on the jar list to signify that while they are there to be installed easier, they are not supported/recommended for use and any support for issues when using them is limited at best.
With the "Unsupported" modpacks these are either due to them being brand new packs that we are unsure of how they will perform (such as Direwolf20-1.16 above), or they are popular enough to warrant being available for 1-click install but they are known to have a very high chance of performance issues, so while it can be installed easier it is still not recommended for use.

Previously available modded/modpack options that have now been moved to the "Unsupported" categories are:
- AT - A Bit of Everything
- Curse - All the Mods 3/4/5/6


JAR List Options that have been added:
- FTB - Direwolf20-1.16 (1.0.0) [Unsupported].
- FTB - Revelation (3.4.0) [Unsupported].
- FTB - University (1.1.0).
- Curse - Project Ozone 3: A New Way Forward (3.3.61) [Unsupported].
- Curse - RLCraft (Beta-2.8.2) [Unsupported].
- Curse - Valhelsia 2 (2.3.0) [Unsupported].
- Curse - Valhelsia 3 (pre7-3.1.0) [Unsupported]

We have also expanded the Forge options to include most older Forge versions, with both the Latest and Recommended being available where applicable and/or where there are more than just a single build between the two in which case just the Latest has been added:
- Forge 1.2.5 (Latest - 3.4.9.171).
- Forge 1.3.2 (Latest - 4.3.5.318).
- Forge 1.4.7 (Latest - 6.6.2.534).
- Forge 1.5.2 (Latest - 7.8.1.737).
- Forge 1.6.4 (Rec./Latest - 9.11.1.1345).
- Forge 1.7.10 (Rec. - 10.13.4.1558).
- Forge 1.8.9 (Rec. - 11.15.1.1722).
- Forge 1.8.9 (Latest - 11.15.1.2318).
- Forge 1.9.4 (Rec. - 12.17.0.1976).
- Forge 1.9.4 (Latest - 12.17.0.2051).
- Forge 1.10.2 (Rec. - 12.18.3.2185).
- Forge 1.11.2 (Rec. - 13.20.1.2386).
- Forge 1.11.2 (Latest - 13.20.1.2558).
- Forge 1.13.2 (Latest - 25.0.219).
- Forge 1.14.4 (Rec. - 28.2.0).
- Forge 1.14.4 (Latest - 28.2.23).
- Forge 1.15.2 (Latest - 31.2.47)
- Forge 1.16.4 (Latest - 35.1.13)
Just like the other plain Forge options - they will wipe the contents of your mods folder on their first install.

From this point on the "Latest" Forge build for the most recent minor release of that version (ie 1.16.4, not 1.16.3) will also be included on the list if it is not the same build as the Recommended build of that Forge version, and will be updated weekly where necessary.

We have also re-added a much older variant of MCPC+ which allows bukkit plugin use alongside Forge 1.2.5 mods:
- CraftBukkit++ 1.2.5 (R4.1-MCPC-SNAPHOT)
This will not wipe the mods folder on first install (same as other Forge+Plugin options).
 

Richard_BN

BeastNode Staff
Dec 18, 2015
552
128
108
The Realm of Obscurity.
December 17th Updates

JAR List Options that have been added:
- Curse - All the Mods 6 (1.3.5) [Unsupported].

JAR List Options that have been removed:

- PixelmonGenerations (8.2.2).
- Curse - All the Mods 6 (1.3.3).
- Forge 1.16.4 (Rec. 35.1.0).
- Vanilla/Spigot/CraftBukkit 1.16.3.

At this time servers should have updated to 1.16.4 - for any servers stuck on 1.16.3 waiting on plugin updates for an update you can continue to use 1.16.3 as you are now if you don't change the jar list option, though it may not show as "Online" on the control panel after your next server restart due to it being removed.
If that is the case and you wish to remain on 1.16.3 for the time being and have it work correctly on the panel simply use the Custom Server JAR option on the jar list and rename the server jar you are using in your servers jar folder to custom_server.jar before a restart.
 

Richard_BN

BeastNode Staff
Dec 18, 2015
552
128
108
The Realm of Obscurity.
December 20th Updates

JAR List Options that have been added:
- Curse - All the Mods 6 (1.3.6b) [Unsupported].
- Curse - Valhelsia 2 (2.3.1) [Unsupported].
- Curse - Valhelsia 3 (3.1.0) [Unsupported].

JAR List Options that have been updated:
- The Fabric 1.16.4 option, updated to include Fabric-API (0.28.3).
To update this option simply delete the jar folder and restart. If you have renamed the Fabric-API.jar file in the mods folder at any time this must also be deleted or it won't auto-remove and update correctly (nothing else in the mods folder is touched so it won't effect your installed mods when updating).

JAR List Options that have been removed:

- Curse - All the Mods 6 (1.3.4c).
 

Richard_BN

BeastNode Staff
Dec 18, 2015
552
128
108
The Realm of Obscurity.
December 21st Updates

JAR List Options that have been added:
- FTB - Direwolf20-1.16 (1.1.1) [Unsupported].

JAR List Options that have been removed:
- Curse - All the Mods 6 (1.3.5).
- Curse - Valhelsia 2 (2.3.0).
- Curse - Valhelsia 3 (pre7-3.1.0).
 

Richard_BN

BeastNode Staff
Dec 18, 2015
552
128
108
The Realm of Obscurity.
December 23rd Updates

JAR List Options that have been added:
- Curse - All the Mods 6 (1.3.7) [Unsupported].
- Curse - Valhelsia 3 (3.1.1) [Unsupported].
- FTB - Direwolf20-1.16 (1.1.2) [Unsupported].

JAR List Options that have been removed:
- FTB - Direwolf20-1.16 (1.0.0).
 

Richard_BN

BeastNode Staff
Dec 18, 2015
552
128
108
The Realm of Obscurity.
December 24th Updates

JAR List Options that have been added:
- AT - A Bit of Everything (3.8.6) [Unsupported].

JAR List Options that have been removed:
- Curse - All the Mods 6 (1.3.6b).
- Curse - Valhelsia 3 (3.1.0).
- FTB - Direwolf20-1.16 (1.1.1).
 

Richard_BN

BeastNode Staff
Dec 18, 2015
552
128
108
The Realm of Obscurity.
December 28th Updates

JAR List Options that have been updated:

- The Fabric 1.14.4 option, updated to include Fabric-API (0.28.4).
- The Fabric 1.15.2 option, updated to include Fabric-API (0.28.4).
- The Fabric 1.16.4 option, updated to include Fabric-API (0.28.4).
To update this option simply delete the jar folder and restart. If you have renamed the Fabric-API.jar file in the mods folder at any time this must also be deleted or it won't auto-remove and update correctly (nothing else in the mods folder is touched so it won't effect your installed mods when updating).

JAR List Options that have been removed:
- AT - A Bit of Everything (3.8.6).
For whatever reason 3.8.6 was removed from the ATLauncher so 3.8.5 is still the latest available build.
 

Richard_BN

BeastNode Staff
Dec 18, 2015
552
128
108
The Realm of Obscurity.
December 28th Updates

JAR List Options that have been added:

- Curse - Valhelsia 3 (3.1.2) [Unsupported].
- FTB - Direwolf20-1.16 (1.2.0) [Unsupported].
- Forge 1.16.4 (Latest - 35.1.28).

NOTE - As with all of the plain Forge options, it will wipe your servers config and mods folders on install. Unless you require the newer Forge build for any mod changes you are making you should not update to this build.
If you do require the update, follow these steps exactly to avoid any issues with your setup:
- Stop your server and log into the server files/FTP.
- Delete the jar folder.
- Make a new folder (any name just something different and memorable so you remember which it is) and move the config and mods folders into it, along with the world folder you are using.
- When done, load the server back up.
- Once it has loaded shut it back down and go back to the server files/FTP.
- Delete the config and mods folders, as well as the folder with the same name as your world.
- When they have deleted, move the contents of the folder you created previously (the config, mods and world folder you moved to it earlier) back out to the main directory (after this is done you can then delete the empty folder).
- Start the server back up.

To continue using the previous "Latest" Forge build after we remove it, without it making your server never show as "Online" on the control panel, follow these steps:
- Log into your server files.
- Go into the /jar directory and rename the Forge file you are using (the name is in the JAR File box on the main page of your control panel) to custom_server.jar exactly (case-sensitive).
- When done, go back to the main page of the control panel and change the drop down jar list from the Forge option you are using (or "Default" if it has already been removed from our list" and select the Custom Server JAR option.
- Restart the server.
It will continue using the same Forge build you have been using, but will continue to show it as Online on the control panel correctly even when we remove that Forge build from our list.


General side note - Forge updates will be checked for every Wednesday from now on, starting today. The "Latest" build will not be updated constantly because there's rarely a need for it (particularly when they drop 11 updates in one day as they did for 1.16.4's Latest over the last couple of days...).
If you require a more recent build than we have on our list before we add it the following Wednesday it will need to be installed manually.