Unresolved MultiVerse Portals error - 1.9 updated

Richard_BN

BeastNode Staff
Dec 18, 2015
564
128
108
The Realm of Obscurity.
This is generally either due to an issue with the plugin itself such as being outdated, or due to another plugin trying to use the same command:

25.04 12:03:24 [Server] INFO org.bukkit.command.CommandException: Unhandled exception executing command 'mvp' in plugin Multiverse-Portals v2.4-b548

Please make sure that nothing else installed uses the '/mvp' command, and make sure that MultiVerse-Portals is up to date for 1.8.8. The latest version on dev.bukkit.org for example is 2.6-b725, whereas you have 2.4-b548 installed.
 
  • Like
Reactions: Jacksharkben

Jacksharkben

Regular
Feb 28, 2016
115
11
38
23
This is generally either due to an issue with the plugin itself such as being outdated, or due to another plugin trying to use the same command:

25.04 12:03:24 [Server] INFO org.bukkit.command.CommandException: Unhandled exception executing command 'mvp' in plugin Multiverse-Portals v2.4-b548

Please make sure that nothing else installed uses the '/mvp' command, and make sure that MultiVerse-Portals is up to date for 1.8.8. The latest version on dev.bukkit.org for example is 2.6-b725, whereas you have 2.4-b548 installed.
Thanks for the help I installed it. But I can't see if it worked right now.
 

Richard_BN

BeastNode Staff
Dec 18, 2015
564
128
108
The Realm of Obscurity.
If you send in a ticket we can check the server to see if it's working - We can't do that from here as forum accounts and billing/multicraft accounts are all separate.
 

Jacksharkben

Regular
Feb 28, 2016
115
11
38
23
If you send in a ticket we can check the server to see if it's working - We can't do that from here as forum accounts and billing/multicraft accounts are all separate.
No thanks it would be faster if I gust get on and see for my self.
 
  • Like
Reactions: Richard_BN

Verum

Regular
Mar 7, 2016
112
73
48
31
Depending on your server I'd generally advise against using multiverse, it takes up far too many resources and the result is rarely worth it.
 
  • Like
Reactions: Jacksharkben

Jacksharkben

Regular
Feb 28, 2016
115
11
38
23
Depending on your server I'd generally advise against using multiverse, it takes up far too many resources and the result is rarely worth it.
It is for a lobby.
 

Richard_BN

BeastNode Staff
Dec 18, 2015
564
128
108
The Realm of Obscurity.
Whether MultiVerse causes issues or not is entirely dependant on the setup of the server - the plugin itself is perfectly fine as long as there is enough RAM to handle the extra world(s) being loaded and that you don't go overboard with it and remove worlds when not in use (as an example I have seen servers with 30+ worlds being loaded due to old worlds never being removed, on hardly any RAM, and people wondering why it wouldn't work....)
 
  • Like
Reactions: Jacksharkben

Jacksharkben

Regular
Feb 28, 2016
115
11
38
23
Whether MultiVerse causes issues or not is entirely dependant on the setup of the server - the plugin itself is perfectly fine as long as there is enough RAM to handle the extra world(s) being loaded and that you don't go overboard with it and remove worlds when not in use (as an example I have seen servers with 30+ worlds being loaded due to old worlds never being removed, on hardly any RAM, and people wondering why it wouldn't work....)
To save ram I put the spawn in the Minigames world.
 

Richard_BN

BeastNode Staff
Dec 18, 2015
564
128
108
The Realm of Obscurity.
On testing the latest stable versions of WorldEdit, MultiVerse-Core and MultiVerse-Portals that are 1.8.8 compatible on a 1.8.8 server I do not have any of these issues. The portal blocks face fine when I set them and it always teleports me to where I set the destination, so I am unable to replicate this issue. Note that if you are using BukGet to install the plugins the latest MultiVerse-Core is their 1.9 update, you need to backdate to the version before.

You should be able to remove the sideways portal blocks, select the area in the portal frame with worldedit and simply do '//replace air portal'. You can use anything as the portal however if they are causing issues, it does not need to be portal blocks - air works fine, as would anything that can be walked through.

The randomly teleporting to the wrong place and suffocating is unlikely to be something we can help with as it is more likely to be a bug in the plugin itself or an incompatibility with something else that is installed. All I can suggest is to set the portals spawn destination again.
 
  • Like
Reactions: Jacksharkben

Jacksharkben

Regular
Feb 28, 2016
115
11
38
23
On testing the latest stable versions of WorldEdit, MultiVerse-Core and MultiVerse-Portals that are 1.8.8 compatible on a 1.8.8 server I do not have any of these issues. The portal blocks face fine when I set them and it always teleports me to where I set the destination, so I am unable to replicate this issue. Note that if you are using BukGet to install the plugins the latest MultiVerse-Core is their 1.9 update, you need to backdate to the version before.

You should be able to remove the sideways portal blocks, select the area in the portal frame with worldedit and simply do '//replace air portal'. You can use anything as the portal however if they are causing issues, it does not need to be portal blocks - air works fine, as would anything that can be walked through.

The randomly teleporting to the wrong place and suffocating is unlikely to be something we can help with as it is more likely to be a bug in the plugin itself or an incompatibility with something else that is installed. All I can suggest is to set the portals spawn destination again.
one more thing this is a 1.9.2 server
 

Richard_BN

BeastNode Staff
Dec 18, 2015
564
128
108
The Realm of Obscurity.
If you change server version you need to update the post/ticket to state so clearly or you will not be getting accurate support.

I updated the test server to 1.9.2 and updated all three plugins to their latest development versions - the portals still work as they should do without issue so I still cannot replicate the issue. All I can suggest is that you make sure you are using the latest development versions of all three plugins and remake the portals - otherwise this is likely a bug in the plugins themselves or an incompatibility with something else you have installed.

http://builds.enginehub.org/job/worldedit?branch=master
http://ci.onarandombox.com/job/Multiverse-Core/
http://ci.onarandombox.com/job/Multiverse-Portals/
 

Verum

Regular
Mar 7, 2016
112
73
48
31
Could you post all your plugin versions and server jar aswell as any errors in your console upon server start and any errors upon people using the portal or you creating them. Will help get a better understanding of it.
 
  • Like
Reactions: Jacksharkben

Jacksharkben

Regular
Feb 28, 2016
115
11
38
23
Could you post all your plugin versions and server jar aswell as any errors in your console upon server start and any errors upon people using the portal or you creating them. Will help get a better understanding of it.
I will get on that soon would it be better to give you the file access
 

Verum

Regular
Mar 7, 2016
112
73
48
31
Ideally yes but I'd prefer you to get into habit of getting the information due to the security risks of giving me direct access to your files, end of day you don't know me or what I'd do on them.
 
  • Like
Reactions: Jacksharkben

Jacksharkben

Regular
Feb 28, 2016
115
11
38
23
Ideally yes but I'd prefer you to get into habit of getting the information due to the security risks of giving me direct access to your files, end of day you don't know me or what I'd do on them.
I am bad at understanding error code. To me if the plugin works I am fine with it.
 

Richard_BN

BeastNode Staff
Dec 18, 2015
564
128
108
The Realm of Obscurity.
In general if a plugin gives errors in the consoles, whether it appears to work or not ingame, it is not working correctly and will be causing other issues. At no point should a server console have errors spamming the console - they always need to be resolved.

As Verum said previously, if you can provide the server version, versions of the relevant plugins (WorldEdit, MultiVerse-Core and MultiVerse-Portals - a general list of the installed plugins, such as the '/plugins' results can also help), the startup logs of the server so we can see if any of these plugins give errors when loading up, and any errors given either ingame or in the server console when trying to use the portals or when creating the portals we may be able to help further. As I said before though I was unable to produce any issues using the correct, latest development builds of the three plugins, and the latest Spigot version, so updating your plugins as needed will most likely resolve the issue.