JAR List Updates November 1st-30th 2020

Discussion in 'JAR List/1-Click Install Updates' started by Richard_BN, Nov 3, 2020.

  1. Richard_BN

    Richard_BN
    BeastNode Staff

    Joined:
    Dec 18, 2015
    Messages:
    549
    Likes Received:
    135
    Trophy Points:
    108
    Gender:
    Male
    Occupation:
    BeastNode Support Agent
    Location:
    The Realm of Obscurity.
    November 3rd Updates

    JAR List Options that have been added:
    - Vanilla 1.16.4.
    - Spigot 1.16.4.
    - PaperSpigot 1.16.4.

    JAR List Options that have been updated:
    - The "Default" option has been updated to run Spigot 1.16.4.
    - BungeeCord to allow for 1.8-1.16.4.
    - The Fabric 1.16.3 option, updated to Fabric 1.16.4 and to use Fabric Loader (0.10.6+build.214) and updated to include Fabric-API (0.25.1+build.416).

    To reiterate what was stated previously:
    New services will now be set up with Spigot again, and will continue to be once Spigot is stable/recommended for future Minecraft builds as well until the Vanilla server performance has been improved.
    This will be noted in the Minecraft Server Information emails sent out on service purchase along with a link to the post HERE on the performance issues in 1.16.4 and potential ways to improve them.


    As always, to update these options if you are already using one of them simply delete the jar folder from the server files and restart the server on the relevant jar list option.
    For Fabric, if you have renamed the Fabric-API.jar file in the mods folder at any time this must also be deleted or it won't auto-remove and update correctly (nothing else in the mods folder is touched so it won't effect your installed mods when updating).

    JAR List Options that have been removed:
    - FTB - Academy (1.3.0).
    - Vanilla 1.16.4 Release Candidate 1.



    Remember to keep up to date with the options tagged with [Latest] on the jarlist if you use them - updates for these are found on the first link below, and the second link lets you know how to update if you use these options:
    https://www.beastnode.com/forums/threads/jar-list-latest-updates.143/
    https://www.beastnode.com/forums/threads/latest-jar-list-options-and-how-when-to-update-them.174/
     
    Last edited: Nov 11, 2020
  2. Richard_BN

    Richard_BN
    BeastNode Staff

    Joined:
    Dec 18, 2015
    Messages:
    549
    Likes Received:
    135
    Trophy Points:
    108
    Gender:
    Male
    Occupation:
    BeastNode Support Agent
    Location:
    The Realm of Obscurity.
    November 4th Updates

    JAR List Options that have been added:
    - Vanilla 1.17 Snapshot 20w45a
     
  3. Richard_BN

    Richard_BN
    BeastNode Staff

    Joined:
    Dec 18, 2015
    Messages:
    549
    Likes Received:
    135
    Trophy Points:
    108
    Gender:
    Male
    Occupation:
    BeastNode Support Agent
    Location:
    The Realm of Obscurity.
    November 11th Updates

    JAR List Options that have been added:
    - Vanilla 1.17 Snapshot 20w46a.

    JAR List Options that have been updated:

    - The Fabric 1.15.2 option, updated to use Fabric Loader (0.10.6+build.214) and updated to include Fabric-API (0.23.1).
    - The Fabric 1.16.4 option, updated to include Fabric-API (0.25.4).
    To update these options simply delete the jar folder and restart. If you have renamed the Fabric-API.jar file in the mods folder at any time this must also be deleted or it won't auto-remove and update correctly (nothing else in the mods folder is touched so it won't effect your installed mods when updating).
     
  4. Richard_BN

    Richard_BN
    BeastNode Staff

    Joined:
    Dec 18, 2015
    Messages:
    549
    Likes Received:
    135
    Trophy Points:
    108
    Gender:
    Male
    Occupation:
    BeastNode Support Agent
    Location:
    The Realm of Obscurity.
    November 15th Updates

    JAR List Options that have been added:
    - Technic - The 1.12.2 Pack (1.2.3).

    JAR List Options that have been updated:

    - The Fabric 1.14.4 option, updated to use Fabric Loader (0.10.7) and updated to include Fabric-API (0.23.2).
    - The Fabric 1.15.2 option, updated to use Fabric Loader (0.10.7).
    - The Fabric 1.16.4 option, updated to use Fabric Loader (0.10.7) and updated to include Fabric-API (0.25.7).
    To update these options simply delete the jar folder and restart. If you have renamed the Fabric-API.jar file in the mods folder at any time this must also be deleted or it won't auto-remove and update correctly (nothing else in the mods folder is touched so it won't effect your installed mods when updating).
     
  5. Richard_BN

    Richard_BN
    BeastNode Staff

    Joined:
    Dec 18, 2015
    Messages:
    549
    Likes Received:
    135
    Trophy Points:
    108
    Gender:
    Male
    Occupation:
    BeastNode Support Agent
    Location:
    The Realm of Obscurity.
    November 18th Updates

    JAR List Options that have been added:
    - AT - Everything Fabric (1.1.0).

    JAR List Options that have been updated:

    - The Fabric 1.16.4 option, updated to include Fabric-API (0.26.0).
    To update this option simply delete the jar folder and restart. If you have renamed the Fabric-API.jar file in the mods folder at any time this must also be deleted or it won't auto-remove and update correctly (nothing else in the mods folder is touched so it won't effect your installed mods when updating).

    JAR List Options that have been removed:
    - Technic - The 1.12.2 Pack (1.2.2).
     
  6. Richard_BN

    Richard_BN
    BeastNode Staff

    Joined:
    Dec 18, 2015
    Messages:
    549
    Likes Received:
    135
    Trophy Points:
    108
    Gender:
    Male
    Occupation:
    BeastNode Support Agent
    Location:
    The Realm of Obscurity.
    November 25th Updates

    JAR List Options that have been added:
    - Vanilla 1.17 Snapshot 20w28a.

    JAR List Options that have been removed:
    - AT - Everything Fabric (1.0.0).
    - Vanilla 1.17 Snapshot 20w25a.
     
  7. Richard_BN

    Richard_BN
    BeastNode Staff

    Joined:
    Dec 18, 2015
    Messages:
    549
    Likes Received:
    135
    Trophy Points:
    108
    Gender:
    Male
    Occupation:
    BeastNode Support Agent
    Location:
    The Realm of Obscurity.
    November 26th Updates

    JAR List Options that have been added:
    - AT - Caved IN (3.0.8.5).
    - Forge 1.16.4 (Rec. - 35.1.0).
    - SpongeVanilla (1.12.2-7.2.4-RC388).
    Note that the SpongeVanilla installs will work in the same manner as the SpongeForge options - unlike the plain Forge options they will not wipe the contents of the mods folder on install so you can install any Sponge plugins you wish to use first.

    We have also added separate options for the Spigot and PaperSpigot 1.15.2 and 1.16.4 options on the jar list that use the startup flags recommended by Aikar for those that wish to try using those instead to see if they help with server performance. These options will always run on the same jar as the normal options for that version (so if you use it and your server is outdated, delete the jar folder and restart as you would for those options).

    Note - As with PaperSpigot this is not always going to help you, there is no universal *this is better* option.
    These are also only recommended for 8GB+ RAM servers - anything less and they may be more counterproductive than helpful (these startup parameters will also cause a much higher allocation of your total RAM so the meter on the control panel will be even less useful - use plugins to check for the accurate RAM usage).

    JAR List Options that have been updated:
    - The Fabric 1.16.4 option, updated to include Fabric-API (0.26.3).
    To update this option simply delete the jar folder and restart. If you have renamed the Fabric-API.jar file in the mods folder at any time this must also be deleted or it won't auto-remove and update correctly (nothing else in the mods folder is touched so it won't effect your installed mods when updating).

    JAR List Options that have been removed:
    - Forge 1.14.4 (Rec. - 28.2.0).
    As Forge 1.14.4 is not particularly widely used - Forge 1.15.2 may also be removed in the future, though it is yet to be seen as to which MC version of Forge is the next commonly used release after Forge 1.12.2.
     

Share This Page