JAR List Updates November 2021 Updates

Richard_BN

BeastNode Staff
Dec 18, 2015
554
128
108
The Realm of Obscurity.
November 3rd Updates


JAR List Options that have been added:
- AT - Fossilized (2.0).
- Technic - Hexxit 2 (1.0.2).
- Vanilla 1.18 Snapshot 21w44a.
- Forge 1.17.1 (37.0.104).

NOTE - As with all of the plain Forge options, it will wipe your servers config and mods folders on install. Unless you require the newer Forge build for any mod changes you are making you should not update to this build.

If you do require the update, follow these steps exactly to avoid any issues with your setup:
- Stop your server and log into the server files/FTP.
- Delete the jar folder.
- Make a new folder (any name just something different and memorable so you remember which it is) and move the config and mods folders into it, along with the world folder you are using.
- When done, load the server back up.
- Once it has loaded shut it back down and go back to the server files/FTP.
- Delete the config and mods folders, as well as the folder with the same name as your world.
- When they have deleted, move the contents of the folder you created previously (the config, mods and world folder you moved to it earlier) back out to the main directory (after this is done you can then delete the empty folder).
- Start the server back up.

To continue using the previous Forge build, without it making your server never show as "Online" on the control panel, follow these steps:
- Log into your server files.
- Go into the /jar directory and rename the Forge file you are using (the name is in the JAR File box on the main page of your control panel) to custom_server.jar exactly (case-sensitive).
- When done, go back to the main page of the control panel and change the drop down jar list from the Forge option you are using (or "Default" if it has already been removed from our list" and select the Custom Server JAR [Java 8] option.
- Restart the server.
It will continue using the same Forge build you have been using, but will continue to show it as Online on the control panel correctly even when we remove that Forge build from our list.


JAR List Options that have been updated:
- The Mohist 1.12.2 option, updated to build 273.
- The Mohist 1.16.5 option, updated to build 839.
- The Fabric 1.16.5 option, updated to include Fabric-API (0.41.3).
- The Fabric 1.17.1 option, updated to include Fabric-API (0.41.3).

To update if you are already using these options simply delete the jar folder from the server files and restart the server.
For those updating the Fabric options if you have renamed the Fabric-API.jar file in the mods folder at any time this must also be deleted or it won't auto-remove and update correctly (nothing else in the mods folder is touched so it won't effect your installed mods when updating).


JAR List Options that have been removed:
- Curse - Valhelsia 3 (3.4.4).




Remember to keep up to date with the options tagged with [Latest] on the jarlist if you use them - updates for these are found on the first link below, and the second link lets you know how to update if you use these options:
https://www.beastnode.com/forums/threads/jar-list-latest-updates.143/
https://www.beastnode.com/forums/threads/latest-jar-list-options-and-how-when-to-update-them.174/
 
Last edited:

Richard_BN

BeastNode Staff
Dec 18, 2015
554
128
108
The Realm of Obscurity.
November 5th Updates


JAR List Options that have been added:
- Curse - All the Mods 6 (1.8.9)[Unsupported].
- FTB - OceanBlock (1.6.0).
- Technic - Hexxit 2 (1.1.0).


JAR List Options that have been removed:
- Technic - Hexxit 2 (1.0.0).
- Forge 1.17.1 (37.0.103).
 

Richard_BN

BeastNode Staff
Dec 18, 2015
554
128
108
The Realm of Obscurity.
November 8th Updates


JAR List Options that have been added:
- Technic - Tekxit Pi (1.0.3).
- Pixelmon Reforged (8.3.3).


JAR List Options that have been removed:
- Curse - All the Mods 6 (1.8.8).
- FTB - OceanBlock (1.5.0).
- Technic - Hexxit 2 (1.0.2).
 

Richard_BN

BeastNode Staff
Dec 18, 2015
554
128
108
The Realm of Obscurity.
November 10th Updates


JAR List Options that have been added:
- FTB - OceanBlock (1.7.0).
- Forge 1.16.5 (36.2.9).
- Forge 1.17.1 (37.0.107).

NOTE - As with all of the plain Forge options, it will wipe your servers config and mods folders on install. Unless you require the newer Forge build for any mod changes you are making you should not update to this build.

If you do require the update, follow these steps exactly to avoid any issues with your setup:
- Stop your server and log into the server files/FTP.
- Delete the jar folder.
- Make a new folder (any name just something different and memorable so you remember which it is) and move the config and mods folders into it, along with the world folder you are using.
- When done, load the server back up.
- Once it has loaded shut it back down and go back to the server files/FTP.
- Delete the config and mods folders, as well as the folder with the same name as your world.
- When they have deleted, move the contents of the folder you created previously (the config, mods and world folder you moved to it earlier) back out to the main directory (after this is done you can then delete the empty folder).
- Start the server back up.

To continue using the previous Forge build, without it making your server never show as "Online" on the control panel, follow these steps:
- Log into your server files.
- Go into the /jar directory and rename the Forge file you are using (the name is in the JAR File box on the main page of your control panel) to custom_server.jar exactly (case-sensitive).
- When done, go back to the main page of the control panel and change the drop down jar list from the Forge option you are using (or "Default" if it has already been removed from our list" and select the Custom Server JAR [Java 8] option.
- Restart the server.
It will continue using the same Forge build you have been using, but will continue to show it as Online on the control panel correctly even when we remove that Forge build from our list.


JAR List Options that have been updated:
- The Mohist 1.16.5 option, updated to build 846, using Forge 1.16.5 36.2.9.
- The Fabric 1.17.1 option, updated to include Fabric-API (0.42.1).

To update if you are already using these options simply delete the jar folder from the server files and restart the server.
For those updating the Fabric options if you have renamed the Fabric-API.jar file in the mods folder at any time this must also be deleted or it won't auto-remove and update correctly (nothing else in the mods folder is touched so it won't effect your installed mods when updating).


JAR List Options that have been changed:
- Technic - Tekxit Pi (1.0.2).
- Pixelmon Reforged (8.3.1).
 

Richard_BN

BeastNode Staff
Dec 18, 2015
554
128
108
The Realm of Obscurity.
November 11th Updates


JAR List Options that have been added:
- Vanilla 1.18 Pre-Release 1.

Note:
Just a reminder that Pre-Releases (and Release Candidates if we get those) are still snapshots - do not update your active worlds to these versions, they do not guarantee that it is safe to update to and then have no issues when 1.18 itself drops.
Only update your active server/worlds when 1.18 itself drops, and in general even then it is advised to wait for a while as there is always a high chance for at least 1.18.1 to come out to fix major issues (as has been the norm for all major releases), or to wait until Spigot/PaperSpigot update per the advice of not using Vanilla at all due to the ongoing performance issues in Vanilla (while they have made some changes in 1.18 that should help with current serverside performance issues to some degree, the changes to the world generation - particularly build height changes - will very likely cause yet another dip in overall performance on Vanilla).

As always if you wish to use these options make a backup of your worlds before you load the server on them.


JAR List Options that have been removed:
- FTB - OceanBlock (1.6.0).
- Forge 1.16.5 (36.2.8).
- Forge 1.17.1 (37.0.104).
 

Richard_BN

BeastNode Staff
Dec 18, 2015
554
128
108
The Realm of Obscurity.
November 12th Updates


JAR List Options that have been added:
- AT - DNS Techpack (1.12.2 - 12.4.1)[All Optional Mods].
- AT - DNS Techpack (1.16.5 - 14.0.0)[No Optional Mods].
- AT - DNS Techpack (1.16.5 - 14.0.0)[All Optional Mods].
- AT - Fossilized (2.0.1.r).


JAR List Options that have been changed:
- AT - DNS Techpack (12.4.1) renamed to (1.12.2 - 12.4.1).
The 14.0.0 update above jumps versions, so for the forseeable future at least we will keep the latest 1.12.2 version of the pack as well.
 

Richard_BN

BeastNode Staff
Dec 18, 2015
554
128
108
The Realm of Obscurity.
November 14th Updates


JAR List Options that have been added:
- AT - Ocean Outlast (v.64).
- Curse - Seablock: Rustic Waters (1.3.9).


JAR List Options that have been removed:
- AT - Fossilized (2.0).
 

Richard_BN

BeastNode Staff
Dec 18, 2015
554
128
108
The Realm of Obscurity.
November 17th Updates


JAR List Options that have been added:
- FTB - Endeavour (1.6.0).
- FTB - OceanBlock (1.8.0).
- Technic - The 1.7.10 Pack (0.10.3).
- Magma 1.16.5 (75c9e73-stable - Forge #36.2.9).
- Custom Server JAR option for Java 17.
- Minecraft 1.18 Pre-Release 2 Pre-Release 3 Pre-Release 4

This pre-release has been added as a separate option to the first pre-release due to requiring Java 17 - ordinarily we would update the same option but if we did this any servers using Pre-Release 1 would crash on startup until updated to Pre-Release 2, which would just cause unnecessary confusion/annoyance. Any further pre-releases will be on this option, and updated the same way as always (delete the jar folder and restart the server while using this option).

Note - Unless your server requires Java 17 (ie it is running on 1.18 Pre-Release 2 or newer) **do not** use the Custom Server JAR option for Java 17. Whether a server version supports newer Java versions or not, it should always be used with the version it was designed around to minimize potential issues.

- Forge 1.17.1 (37.0.109).

NOTE - As with all of the plain Forge options, it will wipe your servers config and mods folders on install. Unless you require the newer Forge build for any mod changes you are making you should not update to this build.

If you do require the update, follow these steps exactly to avoid any issues with your setup:
- Stop your server and log into the server files/FTP.
- Delete the jar folder.
- Make a new folder (any name just something different and memorable so you remember which it is) and move the config and mods folders into it, along with the world folder you are using.
- When done, load the server back up.
- Once it has loaded shut it back down and go back to the server files/FTP.
- Delete the config and mods folders, as well as the folder with the same name as your world.
- When they have deleted, move the contents of the folder you created previously (the config, mods and world folder you moved to it earlier) back out to the main directory (after this is done you can then delete the empty folder).
- Start the server back up.

To continue using the previous Forge build, without it making your server never show as "Online" on the control panel, follow these steps:
- Log into your server files.
- Go into the /jar directory and rename the Forge file you are using (the name is in the JAR File box on the main page of your control panel) to custom_server.jar exactly (case-sensitive).
- When done, go back to the main page of the control panel and change the drop down jar list from the Forge option you are using (or "Default" if it has already been removed from our list" and select the Custom Server JAR [Java 8] option.
- Restart the server.
It will continue using the same Forge build you have been using, but will continue to show it as Online on the control panel correctly even when we remove that Forge build from our list.


JAR List Options that have been updated:
- The Mohist 1.16.5 option, updated to build 852.
- The Fabric 1.14.4, 1.15.2, 1.16.5 and 1.17.1 options, updated to use Fabric Loader (0.12.5).

To update if you are already using these options simply delete the jar folder from the server files and restart the server.


JAR List Options that have been removed:
- AT - Ocean Outlast (v.61).
- Curse - Seablock: Rustic Waters (1.3.8).
 
Last edited:

Richard_BN

BeastNode Staff
Dec 18, 2015
554
128
108
The Realm of Obscurity.
November 19th Updates


JAR List Options that have been updated:
- The Minecraft 1.18 Pre-Release 4 option has been updated to Pre-Release 5.


JAR List Options that have been removed:
- FTB - Endeavour (1.5.0).
- FTB - OceanBlock (1.7.0).
- Technic - The 1.7.10 Pack (0.10.2).
- Forge 1.17.1 (37.0.107).
 

Richard_BN

BeastNode Staff
Dec 18, 2015
554
128
108
The Realm of Obscurity.
November 21st Updates


JAR List Options that have been added:
- Curse - All the Mods 6 (1.8.10)[Unsupported].
- Curse - Roguelike Adventures and Dungeons (1.48).
- FTB - Endeavour (1.7.0).
- FTB - OceanBlock (1.9.0).
- AT - AMPZ Reborn (1.16.5 - 4.0).

As this update for AMPZ Reborn is a Forge/Minecraft version update as well we will be keeping it as a second/separate option (Version 3.9 running on Forge 1.12.2, and 4.0+ running on Forge 1.16.5).

Please note that if you are currently using AMPZ Reborn 3.9 it is NOT recommended to directly update to 4.0 - as it is a vastly different Minecraft version, which means it is also heavily likely that the mods in the pack have changed too, updating using the same server setup (world in particular) is very likely to break things.
If you wish to update stop your server, download a copy of your current server files just in case you decide to roll everything back to the 1.12.2 version of the pack and then delete everything, world included (you can try and run your old world with the updated pack but the chances of everything breaking are extremely high).
Then select and load the new release of AMPZ to install it with a new world generated for it (or to load it with your world if you delete everything except for the world folder from the server files).


JAR List Options that have been changed:
- AT - AMPZ Reborn (3.9) changed to (1.12.2 - 3.9) to note that this version of the modpack is for a different version of Minecraft/Forge.
 

Richard_BN

BeastNode Staff
Dec 18, 2015
554
128
108
The Realm of Obscurity.
November 22nd Updates


JAR List Options that have been updated:
- Vanilla 1.18 Pre-Release 5 to Pre-Release 6.

To update if you already installed Pre-Release 2-5 log into your server files, delete the jar folder and restart the server.


JAR List Options that have been removed:
- Curse - All the Mods 6 (1.8.9).
- Curse - Roguelike Adventures and Dungeons (1.47a).
- FTB - Endeavour (1.6.0).
- FTB - OceanBlock (1.8.0).
 

Richard_BN

BeastNode Staff
Dec 18, 2015
554
128
108
The Realm of Obscurity.
November 24th Updates


JAR List Options that have been added:
- Curse - Engineers Life 2 (1.10).
- Forge 1.16.5 (Latest - 36.2.19).
- Forge 1.17.1 (Latest - 37.0.116).

NOTE - As with all of the plain Forge options, it will wipe your servers config and mods folders on install. Unless you require the newer Forge build for any mod changes you are making you should not update to this build.

If you do require the update, follow these steps exactly to avoid any issues with your setup:
- Stop your server and log into the server files/FTP.
- Delete the jar folder.
- Make a new folder (any name just something different and memorable so you remember which it is) and move the config and mods folders into it, along with the world folder you are using.
- When done, load the server back up.
- Once it has loaded shut it back down and go back to the server files/FTP.
- Delete the config and mods folders, as well as the folder with the same name as your world.
- When they have deleted, move the contents of the folder you created previously (the config, mods and world folder you moved to it earlier) back out to the main directory (after this is done you can then delete the empty folder).
- Start the server back up.

To continue using the previous Forge build, without it making your server never show as "Online" on the control panel, follow these steps:
- Log into your server files.
- Go into the /jar directory and rename the Forge file you are using (the name is in the JAR File box on the main page of your control panel) to custom_server.jar exactly (case-sensitive).
- When done, go back to the main page of the control panel and change the drop down jar list from the Forge option you are using (or "Default" if it has already been removed from our list" and select the Custom Server JAR [Java 8] option.
- Restart the server.
It will continue using the same Forge build you have been using, but will continue to show it as Online on the control panel correctly even when we remove that Forge build from our list.


JAR List Options that have been updated:
- Vanilla 1.18 Pre-Release 6 to Pre-Release 7 Pre-Release 8.
- The Mohist 1.12.2 option, updated to build 274.
- The Mohist 1.16.5 option, updated to build 863 using Forge 1.16.5 (36.2.19).
- The Fabric 1.17.1 option, updated to include Fabric-API (0.43.0).

To update if you are already using these options simply delete the jar folder from the server files and restart the server.
For those updating the Fabric option if you have renamed the Fabric-API.jar file in the mods folder at any time this must also be deleted or it won't auto-remove and update correctly (nothing else in the mods folder is touched so it won't effect your installed mods when updating).
 
Last edited:

Richard_BN

BeastNode Staff
Dec 18, 2015
554
128
108
The Realm of Obscurity.
November 25th Updates


JAR List Options that have been added:
- FTB - Direwolf-16 (1.12.0).
- Minecraft 1.18 Release Candidate 1.


JAR List Options that have been removed:
- Curse - Engineers Life 2 (1.09).
- Forge 1.16.5 (Latest - 36.2.9).
- Forge 1.17.1 (Latest - 37.0.109).
 
Last edited:

Richard_BN

BeastNode Staff
Dec 18, 2015
554
128
108
The Realm of Obscurity.
November 26th Updates


JAR List Options that have been updated:
- Minecraft 1.18 Release Candidate 1 to Pre-Release 2 3.

To update if you already installed Release Candidate 1 simply delete the jar folder from your server files and restart the server on this option.


JAR List Options that have been removed:
- FTB - Direwolf-16 (1.11.0).
 
Last edited:

Richard_BN

BeastNode Staff
Dec 18, 2015
554
128
108
The Realm of Obscurity.
November 29th Updates


JAR List Options that have been updated:
- Minecraft 1.18 Release Candidate 3 to Pre-Release 4.

To update if you already installed Release Candidate 1 simply delete the jar folder from your server files and restart the server on this option.
 

Richard_BN

BeastNode Staff
Dec 18, 2015
554
128
108
The Realm of Obscurity.
November 30th Updates


JAR List Options that have been added:
- AT - DNS Techpack (1.16.5 - 14.1.2)[No Optional Mods].
- AT - DNS Techpack (1.16.5 - 14.1.2)[All Optional Mods].
- Vanilla 1.18.
- Spigot and PaperSpigot 1.18 - further updated over HERE as usual. Note that for the time being, until the Paper team say otherwise, Paper 1.18 builds are EXPERIMENTAL and you use them at your own risk of bugs/issues.

Note - As with all Minecraft version updates, if you plan to update to 1.18 you NEED to stop your server and make a full backup of your server data that is saved locally, not in the server files (this, in general, is a good habit to get into - backups should always be saved off-site and be made regularly, regardless of whether you're updating or not).

If a backup is not made and you update then your world will update to 1.18's changes to Y levels (the area under Y=0 will update and generate automatically for all chunks, new caves/world generation will only be present in a full chunk if that chunk was not generated on 1.17.1 or older already) which will make that world completely unusable on anything but 1.18+ - you CANNOT use a world loaded with 1.18 on 1.17.1 or older without major issues (if it will load at all). There is also never a guarantee (even with minor version releases) that the world won't have issues when updating that if you do not have a backup to roll back to cannot be undone - if you update without a backup (or update and then backdate with the same world) and things break we cannot fix them for you.

Please also bare in mind that until we have any real evidence to the contrary - all performance issues from 1.13-1.17.1 are very likely still present, and may even be a bit worse due to the increased build height and world generation changes. As always once Spigot has had time to squash any immnediate bugs it will be recommended to use Spigot over Vanilla for all servers, with the same recommended tweaks that have been suggested for years now.
- https://www.beastnode.com/forums/threads/minecraft-1-13-performance-issues.914/


JAR List Options that have been updated:
- BungeeCord and Waterfall now both support 1.18.
- "Default" has been updated to Vanilla 1.18.
This is the option that new services are set up with so new services as of now come with Vanilla 1.18. Once Spigot has had a week or two to iron out any major bugs this will be changed to Spigot again (unless 1.18.1 is announced first in which case we will wait until then).

Note that as with all options on the list if you have already ran your server with the Default option and have not deleted the jar folder this option will not update to 1.18. If you plan on updating it would generally be advised to switch to the Vanilla 1.18 option itself, not to stick to the Default option.


JAR List Options that have been removed:
- Vanilla 1.18 Snapshots 21w37a, 21w38a, 21w39a, 21w40a, 21w41a, 21w42a, 21w43a and 21w44a.
- Vanilla 1.18 Pre-Releases 1 and 8
- Vanilla 1.18 Release Candidate 4.


JAR List Options that have been changed:
- Spigot and PaperSpigot 1.17.1 no longer listed as [Latest].
- Vanilla, Spigot and PaperSpigot 1.15.2 are now listed under Unsupported on the jar list. Only the latest 3 major release versions (so in this case 1.16.5, 1.17.1 and 1.18.*) are supported.
- The "Default" option now runs on Java 17 due to Minecraft 1.18+ requiring this - any custom server installations (including options that we have removed from our list that are still being used) should be linked to their relevant Custom Server JAR option so they run on the correct version of Java, as if they are not Java 17 compatible they will crash on startup (if the jar name entered in the JAR File box on your panel does not match something on our system that is set up otherwise - such as the Custom Server JAR options - it uses the "Default" options settings to run from, which now means loading with Java 17).