Richard_BN

BeastNode Staff
Dec 18, 2015
559
128
108
The Realm of Obscurity.
Seem to be the more popular server versions? Most popular modpacks or plugins?
Working from this end it's hard to tell, as I rarely get time to play and I only see the servers that send in tickets, but CraftBukkit/Spigot servers still seem to be going strong! Considering a few years back after the whole Bukkit DMCA Takedown drama everyone thought it was the end of Bukkit (and a lot thought it was going to be the end of hosts.... especially coupled with the EULA!).

Just thought I'd be nosey :) May help with future jar list updates/changes if I know what is definitely being used and what isn't!
 

Richard_BN

BeastNode Staff
Dec 18, 2015
559
128
108
The Realm of Obscurity.
Also - talking of Spigot/CraftBukkit.... I very much agree with md_5 xD:

 

Verum

Regular
Mar 7, 2016
112
73
48
30
Well this is a very varied question, it all depends on the type of server really, for a none mod server that's using likes of Spigot/Bukkit I'd say the most popular version will be the latest but with the combat changes reverted, personally I like to go with the times so have the new system enabled.

As for most popular plugins, it's still the classics you'd expect, essentials, mcmmo, Factions (massivecrafts version) and cratekey plugins are also very popular currently but no specific one as far as I know.
 

Richard_BN

BeastNode Staff
Dec 18, 2015
559
128
108
The Realm of Obscurity.
Surprisingly, from what I see through the tickets, the latest Spigot/CraftBukkit versions aren't actually used that much - at least not in the busier servers I see, the smaller/private servers tend to stick with the latest features. A lot of larger servers are still on 1.7.10/1.8 - hence the picture ^ as I do not understand this... It just means your server can't advance as almost nobody is developing plugins/updates for these versions anymore xD

I have a smallish server I run - 1.9/10's PvP features, mainly the attack cooldown, were the first thing to be disabled but why would you stick to 1.8 or older to avoid this.... when polar bears and shulkers and elytras.... MISSING OUT!

McMMO and Essentials (or EssentialsX now...) will never die out... they will keep going until Bukkit is officially retired I think! Factions... ehh. Never been a fan personally, and I see how much stress it causes server owners doing the support, especially when they haven't used it since before the MassiveCore update and try and use it now - and then try and use a build from like 2013 to get around it.... xD


I am still shocked at how Bukkit has managed to survive so well after the DMCA drama - the Spigot team have done wonders in keeping it going!
 

Verum

Regular
Mar 7, 2016
112
73
48
30
So that's the secret to their success, perhaps I need to downgrade to 1.8 then :P (kidding) but generally these larger servers have their own private devs making and developing plugins for them so they don't see a need to upgrade.

I do agree with Essentials not dying out but I feel like McMMO will start to due to the dev of that plugin, not the friendliest of people and not a lot of progress to the plugin itself for a while now, all it's going to take is someone to make a competing plugin that's half decent.

Yeah, the Spigot staff have done wonders and don't get nearly as much praise as they should for helping keep the community alive.
 
  • Like
Reactions: Richard_BN

Richard_BN

BeastNode Staff
Dec 18, 2015
559
128
108
The Realm of Obscurity.
https://www.spigotmc.org/threads/minecraft-1-11-roadmap.192111/

What md_5 states here in point 3 about the Prisoners Dilemma - Everyone that runs a server should read this in full and consider that when they insist on still using 1.7/8 bukkit.

When CraftBukkit/Spigot 1.11 is stable enough for general use and plugins are starting to update, we will likely be removing 1.7.10 from our jar list as we only keep the last few major releases on the list, so it really is time to start getting things up to date! At the latest when 1.12 is out 1.7.10 will be removed, but there really is no valid reason to still be using CraftBukkit 1.7.10/1.8 - the changes most people dislike in 1.9/1.10 are the PvP changes which you can disable with a number of plugins anyway xD