BeastNode Game Server Hosting

Checkout our new range of Cheap Game Server Hosting! Including Rust, Terraria and Valheim!

Starting at only $2.11/mo!


Don't worry our Minecraft Servers are here to stay!

Minecraft Hosting Game Servers


Installing Custom Builds of Forge and/or Custom Mods (Forge 1.16.5 and Older)

NOTE:
Please make sure it is Forge 1.16.5 or older that you require before reading this guide - if you require Forge 1.17.1 or newer the installation process is different! There is a guide for 1.17.1 and newer here: 
Installing Custom Builds of Forge and/or Custom Mods (Forge 1.17.1 and Newer)

For custom Fabric build installations please follow the guide here:
Installing Custom Builds of Fabric and/or Custom Mods



Installing Forge 1.16.5 and older through the 1-click Install list on your control panel

If the Forge version/build you need is an available option on our list then you do not need to install it manually.

We will always try and have the Recommended (and Latest builds if they are newer) for all Forge releases available (final minor versions only, for example 1.16.5 but not 1.16/.1/.2./.3/.4) - with the latest builds being updated once a week where needed. If any of the available builds will work for the mods you are installing you can install them easily following these steps:

- Log into your mc.beastnode.com account and go to your servers main page (Where the Start/Stop/Restart buttons are found).
- Change the drop down list of server options (Will be set to 'Default' if you have never changed this) to the Forge version and build you wish to install.
- Once the page refreshes to confirm the change, restart the server.

This will install the selected Forge version. Note that when you run one of the plain Forge options it will completely wipe the contents of the mods and config folders (to avoid version conflicts etc...) so make sure you are installing Forge by itself first before installing your mods!

Please note that if you delete the jar folder, or it's contents, the server will reinstall Forge on the next restart which will again wipe the mods and config folders.

 



Step by step on installing custom Forge 1.16.5 and older builds

First, download the build you need from: http://files.minecraftforge.net/ - Make sure to select the specific version you need (as, for example, Forge 1.7.10 mods will only work with a Forge 1.7.10 server):


And to download the 'Installer' file for that version (For these examples we will use the current latest version of 1.16.5 - Use whichever build/version you require):



Once downloaded, double click the .jar file to start the setup process:



You will be given 3 options in the window that opens - select "Install server," then select the directory to download the files to by clicking the "..." button at the bottom. Then click OK and let it complete the process and click OK on the pop up that comes up when it is done installing.

Once it is finished, you should find the server files in the directory you set it to install to:



In this example I installed the files to the same directory the installer was in. The highlighted files (the installer jar, the .log and, in newer versions that have it, the <version>.json file) can be deleted at this stage.

Upload both .jar files (Forge and Vanilla MC - not the installer file) and the libraries folder to your server's jar directory via FileZilla - Make sure to remove all previous files from the jar folder first to avoid any issues - So you should have something like this:


(Note that you will likely have more folders listed in the top panel, the example server used's files had been wiped prior to the Forge installation - it is just to show that they are placed inside the jar directory)

You will now need to rename the Forge jar accordingly - if you wish to use Java 8 you need to rename the Forge jar to custom_server.jar, for Java 11 rename the Forge jar to custom_server_j11.jar and for Java 16 rename the Forge jar to custom_server_j16.jar (most Forge 1.16.5 and older versions do not work with Java 11 or 16, so it is strongly recommended to use Java 8 unless specifically required).
For this example I have renamed the jar for Java 8:



Now go to your servers control panel and change the drop down list to the correct Custom Server JAR option at the top of the list:


And once the page has refreshed to confirm this selection - start the server up!



Installing your mods once Forge is set up

Now you can download your favorite mods and simply upload the zip/jar files for them to the "mods" folder of your server to install them (via FileZilla as above). Make sure to pay attention to the version of Forge the mods you want to install are using and make sure you have the correct version of Forge the mod needs. Some mods require other mods to work as well - make sure to check the mods documentation for any dependancies and install those too!
Note that not every mod installs via this method, so always make sure to read the full directions for the particular mod you are installing.

Once you have uploaded all mods you wish to use, restart the server to load them - If the mods are compatible with the installed Forge version and build, and have any dependancies installed also on the correct versions, your server should start up fine.

Tip: Install mods one at a time (including any dependancies for that mod) so that you can always determine if a single mod is the cause of your server not working - if you upload a lot of mods at once it is harder to isolate which mod may be causing issues.
 
Once the mods you wish to use are all installed and working fine, it is recommended to shut it down and then follow these steps to load a new world generated by those mods specifically:
- Enter a new world name in the World box (can be anything, just not the name of a world that has already been created unless you are uploading your own world folder for it to load).
- Hit Save at the bottom of the page.
Then if you are using a world generation mod that requires a specific level-type (for this example lets say you have installed Biomes O Plenty) follow these steps too:
- Go to Files > Config Files on your control panel and open the Server Settings.
- Change the level-type option to what your mod requires (for Biomes O Plenty for example, change it to BIOMESOP all in capitals for older versions or biomesoplenty in all lowercase for newer versions - check their documentation for which you need).
- Save changes to the file.
Then start the server back up to load a new world up, generated specifically by the mods you are using (so all natural ores/mods/buildings etc... are spawned correctly).


**Note: As with any mods, the client side is required to be modded as well (with the same version mods) for you to be able to join a modded server. There are various guides and videos on how to do this - a quick Google will provide the information needed.

**Note that some mods are clientside-only, or singleplayer-only and cannot be used on the server!
Clientside only mods will work fine if they are installed on your launcher but not on the server, and will commonly crash the server if installed on it if they are not set to disable when loaded serverside by the devs (examples being HUD mods, most minimap mods or Optifine).
Singleplayer only mods simply cannot be used with a server at all. It is rare for a mod to be singleplayer only any more, but this can come up here and there.
  • 85 Users Found This Useful
Was this answer helpful?

Related Articles

Installing A Modpack Not On The Jar List (Forge 1.17.1 and Newer)

NOTE:Please make sure the modpack runs on Forge 1.17.1 or newer before reading this guide - if...

How To Change Between Vanilla / CraftBukkit / Other Mods

Here is how to change between CraftBukkit and Vanilla:   1.  Log into your Multicraft account...

Cauldron/KCauldron Mod Incompatibilities

There are a small handful of mods that will not work with Cauldron or KCauldron and must be...

How To Use Plugins on a Modded/Forge Server

Most mods and mod packs do not support Bukkit plugins as they are based off of vanilla Minecraft....

Installing Custom Builds of Forge and/or Custom Mods (Forge 1.17.1 and Newer)

NOTE:Please make sure it is Forge 1.17.1 or newer that you require before reading this guide - if...